Logo-amall

When can we expect the crowdsec plugin to be out of beta and included in the OPNSense repo? 22.7?

Last active 13 days ago

26 replies

14 views

  • TR

    When can we expect the crowdsec plugin to be out of beta and included in the OPNSense repo? 22.7?

  • AL

    Thread automatically created by @mention in <#922594665100881920>. If you have a suggestion or a bug report please file it directly on our github at whichever repo is suitable. CrowdSec agent: Parser/Scenario: Docs: Bouncer: The specific repo (e.g. ) To make sure we register your request correctly.

  • HA

    i'm already on 22.1.7_1, i don't see it yet

  • AL

    When can we expect the crowdsec plugin to be out of beta and included in the OPN (2022-05-25)

  • HA

    oops, 22.1.8 now.

  • HA

    Did some digging: https://github.com/opnsense/plugins/compare/22.1.7...22.1.8

  • TR

    Thanks, looks like they are getting closer.. maybe it will make it for 22.7

  • BO

    22.1.8 dropped

  • KL

    @mention maybe you have comments?

  • HA

    yea I didn't see it in opnsense updates for 22.1.8

  • TR

    22.1.9 was released, still no plugin

  • KL

    wtf

  • KL

    @mention Got any idea what's going on? Can we do anything to speed up the process? Can I poke their CEO?

  • HA

    yea that's so strange. 😭

  • KL

    I just poked him. I'll let you guys know when I hear something.

  • BO

    22.1.10 came out and still no crowdsec. They also noted: "This release will be the last of the 22.1 series. The release candidate for 22.7 will be available next week and the release date for the final version is July 28" So maybe 22.7.x will have it????

  • KL

    Yes. @mention just prepared packages for 22.7. We missed the 22.1 release. You can still install CrowdSec there though - just a bit more cumbersome. I am sure @mention can elaborate

  • MM

    Try "pkg install os-crowdsec-devel"

  • BO

    Awesome. Thanks @mention <3

  • TR

    @mention is the "pkg install os-crowdsec-devel" for 22.1.x or 22.7??

  • KL

    22.1. It'll be available to install like any other package on 22.7 really soon if it isn't already

  • TE

    Nice. It's not (yet) shown in the plugin menu but searching for it in the repo's will get this: root@OPNsense:~ # pkg search crowdsec crowdsec-1.3.4_1 CrowdSec lightweight and collaborative security engine crowdsec-firewall-bouncer-0.0.23.r2_1 CrowdSec bouncer written in golang for firewalls os-crowdsec-devel-0.2 Lightweight and collaborative security engine

  • KL

    Yeah the os- package is missing. It's what provides the menus in OPNsense

  • TR

    Thanks @mention !!

  • TR

    Can confirm its available in 22.7 as a regular plugin, works perfectly, Thanks for all the hard work!

  • KL

    Thanks for the feedback!

Last active 13 days ago

26 replies

14 views